24V heater cartridge failing to maintain temperature

24V heater cartridge failing to maintain temperature

Hello, I purchased a Mosquito for Creality hotend, plus a 50W heating cartridge and thermistor. I installed it this week, but I've immediately run into an issue with it. 

I have it installed on an Ender3 with an SKR Mini E3 V2, using Marlin with the modifications outlined in the product information for the cartridge & thermistor. 

This morning, I was able to run a few small test prints. This worked for perhaps a total of 30 minutes of print time, but eventually I became unable to heat the cartridge above ~191C. The temperature would stall out and trigger thermal runaway protection. This happens every time I try heating the hotend now. 

What can I do to troubleshoot this? The cartridge and thermistor are brand new and apparently somewhat functional -- maybe I'm too computer-brained, but I don't usually expect stuff to 'sort-of' work in this manner, so I don't think they're actually broken. That said, this is the first time I've swapped these parts out so I'm not really sure what to check. I've tried reseating the thermistor as well as reinstalling the JST connector to its cable, neither of which made any difference. 

Any ideas?